Issue Sending Invoices

Incident Report for Rose Rocket

Resolved

This incident has been resolved.
Posted Jan 16, 2026 - 10:28 EST

Identified

We're currently investigating a potential issue impacting sending invoices. You may experience timeouts. We'll provide updates as we learn more.
Posted Jan 16, 2026 - 09:36 EST
This incident affected: Core TMS.